// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\b[SMLX]+\b)|(Univerzální)|(\d+\s*-\s*\d+\s*let)").unwrap();
let string = "Dámské mikinošaty bez potisku - Černá M - volný střih
Dámské mikinošaty bez potisku - Černá XS - volný střih
Taška Happy Nature Příroda - Černá Univerzální
Čepice Západ - Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - Hořčicová - okrově žlutá L";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}