import Foundation
let pattern = #"(\b[SMLX]+\b)|(Univerzální)|(\d+\s*-\s*\d+\s*let)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Dámské mikinošaty bez potisku - Černá M - volný střih
Dámské mikinošaty bez potisku - Černá XS - volný střih
Taška Happy Nature Příroda - Černá Univerzální
Čepice Západ - Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - Hořčicová - okrově žlutá L
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)