use strict;
my $str = 'Dámské mikinošaty bez potisku - Černá M - volný střih
Dámské mikinošaty bez potisku - Černá XS - volný střih
Taška Happy Nature Příroda - Černá Univerzální
Čepice Západ - Šedá Univerzální
Dětská mikina bez kapuce Never stop dreaming - Karmínově růžová 9 - 11 let
Dámské tričko Štěstí - Hořčicová - okrově žlutá L';
my $regex = qr/(\b[SMLX]+\b)|(Univerzální)|(\d+\s*-\s*\d+\s*let)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}