import re
regex = re.compile(r"(\b[SMLX]+\b)|(Univerzální)|(\d+\s*-\s*\d+\s*let)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Dámské mikinošaty bez potisku - Černá M - volný střih\n"
"Dámské mikinošaty bez potisku - Černá XS - volný střih\n"
"Taška Happy Nature Příroda - Černá Univerzální\n"
"Čepice Západ - Šedá Univerzální\n"
"Dětská mikina bez kapuce Never stop dreaming - Karmínově růžová 9 - 11 let\n"
"Dámské tričko Štěstí - Hořčicová - okrově žlutá L")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")