#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.*?class="[^"]*_2s25 ._606w[^"]*".*?href="([^"]+)".*?<\/a>"
Local $sString = "<a class=""asdfasdfsadf" & @CRLF & _
"" & @CRLF & _
"<a class="_2s25 ._606w"bla bla bla bla bla bla sdafjkasdfa href="https://www.facebook.com/AnteSoftTech" bla bla bla title="bla bla" ......................<img>bla</img>.<span></span>..................................</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")