import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?class=\"[^\"]*_2s25 ._606w[^\"]*\".*?href=\"([^\"]+)\".*?<\\/a>";
final String string = "<a class=\"\"asdfasdfsadf\n\n"
+ "<a class=\"_2s25 ._606w\"bla bla bla bla bla bla sdafjkasdfa href=\"https://www.facebook.com/AnteSoftTech\" bla bla bla title=\"bla bla\" ......................<img>bla</img>.<span></span>..................................</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}