import re
regex = re.compile(r"<a.*?class=\"[^\"]*_2s25 ._606w[^\"]*\".*?href=\"([^\"]+)\".*?<\/a>")
test_str = ("<a class=\"\"asdfasdfsadf\n\n"
"<a class=\"_2s25 ._606w\"bla bla bla bla bla bla sdafjkasdfa href=\"https://www.facebook.com/AnteSoftTech\" bla bla bla title=\"bla bla\" ......................<img>bla</img>.<span></span>..................................</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")