$re = '/<a.*?class="[^"]*_2s25 ._606w[^"]*".*?href="([^"]+)".*?<\/a>/';
$str = '<a class=""asdfasdfsadf
<a class="_2s25 ._606w"bla bla bla bla bla bla sdafjkasdfa href="https://www.facebook.com/AnteSoftTech" bla bla bla title="bla bla" ......................<img>bla</img>.<span></span>..................................</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);