using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?class=""[^""]*_2s25 ._606w[^""]*"".*?href=""([^""]+)"".*?<\/a>";
string input = @"<a class=""asdfasdfsadf
<a class=""_2s25 ._606w""bla bla bla bla bla bla sdafjkasdfa href=""https://www.facebook.com/AnteSoftTech"" bla bla bla title=""bla bla"" ......................<img>bla</img>.<span></span>..................................</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}