using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|;)""(?:""|[^"";])*[\n\r]+(?:""|[^"";])*""";
string input = @"test;""123"";""this description with new line feed below should be
matched by regex"";test;""1.0""
NewLine1;""test - this one should not be captured by the regex but its being captured "";test;1
NewLine2;""test that went wrong""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}