$re = '/(^|;)"(?:""|[^";])*[\n\r]+(?:""|[^";])*"/m';
$str = 'test;"123";"this description with new line feed below should be
matched by regex";test;"1.0"
NewLine1;"test - this one should not be captured by the regex but its being captured ";test;1
NewLine2;"test that went wrong"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);