const regex = /(^|;)"(?:""|[^";])*[\n\r]+(?:""|[^";])*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|;)"(?:""|[^";])*[\\n\\r]+(?:""|[^";])*"', 'gm')
const str = `test;"123";"this description with new line feed below should be
matched by regex";test;"1.0"
NewLine1;"test - this one should not be captured by the regex but its being captured ";test;1
NewLine2;"test that went wrong"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}