# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(a);(.*?);(.*?)$/\3/gm;t' <<< "a;b;c
a;x;23
b;b;12"