$re = '/^(a);(.*?);(.*?)$/m';
$str = 'a;b;c
a;x;23
b;b;12';
$subst = "\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;