package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(a);(.*?);(.*?)$`)
var str = `a;b;c
a;x;23
b;b;12`
var substitution = "\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}