// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(a);(.*?);(.*?)$").unwrap();
let string = "a;b;c
a;x;23
b;b;12";
let substitution = "\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}