use strict;
my $str = 'a;b;c
a;x;23
b;b;12';
my $regex = qr/^(a);(.*?);(.*?)$/mp;
my $subst = '\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";