import Foundation
let pattern = #"^(a);(.*?);(.*?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a;b;c
a;x;23
b;b;12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)