import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.gif\\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?\"";
final String string = "\n"
+ "<img src=\"https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g\" /> ";
final String subst = ".gif\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}