const regex = /\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.gif\\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?"', 'gm')
const str = `
<img src="https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g"  /> `;
const subst = `.gif"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);