# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?\""
test_str = ("\n"
	"<img src=\"https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g\"  /> ")
subst = ".gif\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
    print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.