# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)[^\d<]*|<sup>[^\d<]*)\K\d+/{{{$0}}}/g;t' <<< "<sup> 1</sup>
<sup> 1, 2</sup>
<sup>1, 2, 3</sup>
<sup>1, 2, 3\-14</sup>
<sup>1, 2, 3- 44</sup>"