$re = '/(?:\G(?!\A)[^\d<]*|<sup>[^\d<]*)\K\d+/';
$str = '<sup> 1</sup>
<sup> 1, 2</sup>
<sup>1, 2, 3</sup>
<sup>1, 2, 3\\-14</sup>
<sup>1, 2, 3- 44</sup>';
$subst = "{{{$0}}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;