use strict;
my $str = '<sup> 1</sup>
<sup> 1, 2</sup>
<sup>1, 2, 3</sup>
<sup>1, 2, 3\\-14</sup>
<sup>1, 2, 3- 44</sup>';
my $regex = qr/(?:\G(?!\A)[^\d<]*|<sup>[^\d<]*)\K\d+/p;
my $subst = '{{{$0}}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";