#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\G(?!\A)[^\d<]*|<sup>[^\d<]*)\K\d+"
Local $sString = "<sup> 1</sup>" & @CRLF & _
"<sup> 1, 2</sup>" & @CRLF & _
"<sup>1, 2, 3</sup>" & @CRLF & _
"<sup>1, 2, 3\-14</sup>" & @CRLF & _
"<sup>1, 2, 3- 44</sup>"
Local $sSubst = "{{{$0}}}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)