const regex = /(?:\G(?!\A)[^\d<]*|<sup>[^\d<]*)\K\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)[^\\d<]*|<sup>[^\\d<]*)\\K\\d+', 'g')
const str = `<sup> 1</sup>
<sup> 1, 2</sup>
<sup>1, 2, 3</sup>
<sup>1, 2, 3\\-14</sup>
<sup>1, 2, 3- 44</sup>`;
const subst = `{{{$0}}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);