re = /(?:\G(?!\A)[^\d<]*|<sup>[^\d<]*)\K\d+/
str = '<sup> 1</sup>
<sup> 1, 2</sup>
<sup>1, 2, 3</sup>
<sup>1, 2, 3\\-14</sup>
<sup>1, 2, 3- 44</sup>'
subst = '{{{$0}}}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result