using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)[^\d<]*|<sup>[^\d<]*)\K\d+";
string substitution = @"{{{$0}}}";
string input = @"<sup> 1</sup>
<sup> 1, 2</sup>
<sup>1, 2, 3</sup>
<sup>1, 2, 3\-14</sup>
<sup>1, 2, 3- 44</sup>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}