#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+\.|[a-zA-Z ])*$"
Local $sString = " -> Match" & @CRLF & _
"Foo" & @CRLF & _
"Foo Bar" & @CRLF & _
"Foo 1. Bar" & @CRLF & _
"Foo 11. Bar" & @CRLF & _
"1. Foo 11. Bar" & @CRLF & _
" -> No Match" & @CRLF & _
"Foo 1 Bar" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")