using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d+\.|[a-zA-Z ])*$";
string input = @" -> Match
Foo
Foo Bar
Foo 1. Bar
Foo 11. Bar
1. Foo 11. Bar
-> No Match
Foo 1 Bar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}