re = /^(?:\d+\.|[a-zA-Z ])*$/m
str = ' -> Match
Foo
Foo Bar
Foo 1. Bar
Foo 11. Bar
1. Foo 11. Bar
-> No Match
Foo 1 Bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end