package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+\.|[a-zA-Z ])*$`)
var str = ` -> Match
Foo
Foo Bar
Foo 1. Bar
Foo 11. Bar
1. Foo 11. Bar
-> No Match
Foo 1 Bar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}