import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d+\\.|[a-zA-Z ])*$";
final String string = " -> Match\n"
+ "Foo\n"
+ "Foo Bar\n"
+ "Foo 1. Bar\n"
+ "Foo 11. Bar\n"
+ "1. Foo 11. Bar\n"
+ " -> No Match\n"
+ "Foo 1 Bar\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}