$re = '/^(?:\d+\.|[a-zA-Z ])*$/m';
$str = ' -> Match
Foo
Foo Bar
Foo 1. Bar
Foo 11. Bar
1. Foo 11. Bar
-> No Match
Foo 1 Bar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);