const regex = new RegExp('^(?:\\d+\\.|[a-zA-Z ])*$', 'gm')
const str = ` -> Match
Foo
Foo Bar
Foo 1. Bar
Foo 11. Bar
1. Foo 11. Bar
-> No Match
Foo 1 Bar
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}