#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)<iframe.+src="https?:\/\/(?:www.)?youtu\.?be(?:\.com)?.+<\/iframe>"
Local $sString = "<div>" & @CRLF & _
" <iframe src="https://youtube.com"></iframe>" & @CRLF & _
" <iframe src="http://www.youtube.com"></iframe>" & @CRLF & _
" <iframe class="test" src="http://youtu.be/123"></iframe>" & @CRLF & _
" <iframe src="https://yoursite-is-safe-from-gdpr.com"></iframe>" & @CRLF & _
"</div>"
Local $sSubst = "<div>You must accept cookies before seeing this video content</div>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)