package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<iframe.+src="https?:\/\/(?:www.)?youtu\.?be(?:\.com)?.+<\/iframe>`)
var str = `<div>
<iframe src="https://youtube.com"></iframe>
<iframe src="http://www.youtube.com"></iframe>
<iframe class="test" src="http://youtu.be/123"></iframe>
<iframe src="https://yoursite-is-safe-from-gdpr.com"></iframe>
</div>`
var substitution = "<div>You must accept cookies before seeing this video content</div>"
fmt.Println(re.ReplaceAllString(str, substitution))
}