import re
regex = re.compile(r"<iframe.+src=\"https?:\/\/(?:www.)?youtu\.?be(?:\.com)?.+<\/iframe>", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<div>\n"
" <iframe src=\"https://youtube.com\"></iframe>\n"
" <iframe src=\"http://www.youtube.com\"></iframe>\n"
" <iframe class=\"test\" src=\"http://youtu.be/123\"></iframe>\n"
" <iframe src=\"https://yoursite-is-safe-from-gdpr.com\"></iframe>\n"
"</div>")
subst = "<div>You must accept cookies before seeing this video content</div>"
result = regex.sub(subst, test_str)
if result:
print(result)