// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<iframe.+src="https?:\/\/(?:www.)?youtu\.?be(?:\.com)?.+<\/iframe>"#).unwrap();
let string = "<div>
<iframe src=\"https://youtube.com\"></iframe>
<iframe src=\"http://www.youtube.com\"></iframe>
<iframe class=\"test\" src=\"http://youtu.be/123\"></iframe>
<iframe src=\"https://yoursite-is-safe-from-gdpr.com\"></iframe>
</div>";
let substitution = "<div>You must accept cookies before seeing this video content</div>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}