const regex = /<iframe.+src="https?:\/\/(?:www.)?youtu\.?be(?:\.com)?.+<\/iframe>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe.+src="https?:\\\/\\\/(?:www.)?youtu\\.?be(?:\\.com)?.+<\\\/iframe>', 'gmi')
const str = `<div>
<iframe src="https://youtube.com"></iframe>
<iframe src="http://www.youtube.com"></iframe>
<iframe class="test" src="http://youtu.be/123"></iframe>
<iframe src="https://yoursite-is-safe-from-gdpr.com"></iframe>
</div>`;
const subst = `<div>You must accept cookies before seeing this video content</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);