$re = '/<iframe.+src="https?:\/\/(?:www.)?youtu\.?be(?:\.com)?.+<\/iframe>/mi';
$str = '<div>
<iframe src="https://youtube.com"></iframe>
<iframe src="http://www.youtube.com"></iframe>
<iframe class="test" src="http://youtu.be/123"></iframe>
<iframe src="https://yoursite-is-safe-from-gdpr.com"></iframe>
</div>';
$subst = "<div>You must accept cookies before seeing this video content</div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;