$re = '/(?i)^(table|figure)/m';
$str = 'Table 1. Findings. # Matches.
This header contains a table. # Does not match; \'table\' is not at the beginning.
figure 1. An illustrative diagram. # Matches, thanks to the case-insensitive modifier.
TABLE 2: Limitations. # Matches, thanks to the case-insensitive modifier.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);