re = /(?i)^(table|figure)/m
str = 'Table 1. Findings. # Matches.
This header contains a table. # Does not match; \'table\' is not at the beginning.
figure 1. An illustrative diagram. # Matches, thanks to the case-insensitive modifier.
TABLE 2: Limitations. # Matches, thanks to the case-insensitive modifier.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end