import re
regex = re.compile(r"(?i)^(table|figure)", flags=re.MULTILINE)
test_str = ("Table 1. Findings. # Matches.\n\n"
"This header contains a table. # Does not match; 'table' is not at the beginning.\n\n"
"figure 1. An illustrative diagram. # Matches, thanks to the case-insensitive modifier.\n"
"TABLE 2: Limitations. # Matches, thanks to the case-insensitive modifier.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")