#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{5,12}$)(?=(?:[^a-zA-Z\u0590-\u05fe\n]*[a-zA-Z\u0590-\u05fe]){4}[^a-zA-Z\u0590-\u05fe\n]*$)[a-zA-Z\u0590-\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\u0590-\u05fe]{0,4}$"
Local $sString = "abcd123efgh" & @CRLF & _
"abc123efgh" & @CRLF & _
"abc123efg" & @CRLF & _
"ab123efg" & @CRLF & _
"ab123ef" & @CRLF & _
"a123ef" & @CRLF & _
"a123e" & @CRLF & _
"ab123c" & @CRLF & _
"abc123d" & @CRLF & _
"123abcd" & @CRLF & _
"123e" & @CRLF & _
"123e"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")