# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.{5,12}$)(?=(?:[^a-zA-Z\u0590-\u05fe\n]*[a-zA-Z\u0590-\u05fe]){4}[^a-zA-Z\u0590-\u05fe\n]*$)[a-zA-Z\u0590-\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\u0590-\u05fe]{0,4}$"
test_str = ("abcd123efgh\n"
"abc123efgh\n"
"abc123efg\n"
"ab123efg\n"
"ab123ef\n"
"a123ef\n"
"a123e\n"
"ab123c\n"
"abc123d\n"
"123abcd\n"
"123e\n"
"123e")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.