$re = '/^(?=.{5,12}$)(?=(?:[^a-zA-Z\u0590-\u05fe\n]*[a-zA-Z\u0590-\u05fe]){4}[^a-zA-Z\u0590-\u05fe\n]*$)[a-zA-Z\u0590-\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\u0590-\u05fe]{0,4}$/m';
$str = 'abcd123efgh
abc123efgh
abc123efg
ab123efg
ab123ef
a123ef
a123e
ab123c
abc123d
123abcd
123e
123e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);