const regex = /^(?=.{5,12}$)(?=(?:[^a-zA-Z\u0590-\u05fe\n]*[a-zA-Z\u0590-\u05fe]){4}[^a-zA-Z\u0590-\u05fe\n]*$)[a-zA-Z\u0590-\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\u0590-\u05fe]{0,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{5,12}$)(?=(?:[^a-zA-Z\\u0590-\\u05fe\\n]*[a-zA-Z\\u0590-\\u05fe]){4}[^a-zA-Z\\u0590-\\u05fe\\n]*$)[a-zA-Z\\u0590-\\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\\u0590-\\u05fe]{0,4}$', 'gm')
const str = `abcd123efgh
abc123efgh
abc123efg
ab123efg
ab123ef
a123ef
a123e
ab123c
abc123d
123abcd
123e
123e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}