using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{5,12}$)(?=(?:[^a-zA-Z\u0590-\u05fe\n]*[a-zA-Z\u0590-\u05fe]){4}[^a-zA-Z\u0590-\u05fe\n]*$)[a-zA-Z\u0590-\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\u0590-\u05fe]{0,4}$";
string input = @"abcd123efgh
abc123efgh
abc123efg
ab123efg
ab123ef
a123ef
a123e
ab123c
abc123d
123abcd
123e
123e";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}