import Foundation
let pattern = #"^(?=.{5,12}$)(?=(?:[^a-zA-Z\u0590-\u05fe\n]*[a-zA-Z\u0590-\u05fe]){4}[^a-zA-Z\u0590-\u05fe\n]*$)[a-zA-Z\u0590-\u05fe]{0,4}[0-9]{3,8}[a-zA-Z\u0590-\u05fe]{0,4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd123efgh
abc123efgh
abc123efg
ab123efg
ab123ef
a123ef
a123e
ab123c
abc123d
123abcd
123e
123e
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)